Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 112

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 112

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 112

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 112

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /www/htdocs/w0097c3c/rs-forum/phpBB3/includes/bbcode.php on line 112
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3824: Cannot modify header information - headers already sent by (output started at /includes/bbcode.php:483)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3826: Cannot modify header information - headers already sent by (output started at /includes/bbcode.php:483)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3827: Cannot modify header information - headers already sent by (output started at /includes/bbcode.php:483)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3828: Cannot modify header information - headers already sent by (output started at /includes/bbcode.php:483)
Realsoft Forum • View topic - Known problems with Linux version

Known problems with Linux version

Moderator: odubtaig

Postby jounihat » Sunday 27. February 2005, 07:02

I have the libraries in /lib, and I tried the script in the first place (and the INSTALLDIR is right too). When I try the Realsoft3D binary file, I get an error:

"Realsoft3D: error while loading shared libraries: libr3wid2.so: cannot open shared object file: No such file or directory"

The file is in Realsoft3D/lib.
Jouni Hätinen

"Space. It seems to go on and on forever. But then you get to the end, and a gorilla starts throwing barrels at you."
-Fry
User avatar
jounihat
 
Posts: 119
Joined: Tuesday 28. October 2003, 18:06
Location: Vihti, Finland

Postby jounihat » Sunday 27. February 2005, 07:25

Yes! I got it now. I just changed the line of the script a bit:

LD_ASSUME_KERNEL=2.4.1
to
LD_ASSUME_KERNEL=2.6.10

Pretty simple. I just didn't notice that line before.
Jouni Hätinen

"Space. It seems to go on and on forever. But then you get to the end, and a gorilla starts throwing barrels at you."
-Fry
User avatar
jounihat
 
Posts: 119
Joined: Tuesday 28. October 2003, 18:06
Location: Vihti, Finland

Postby Guest » Sunday 27. February 2005, 13:55

Hi, it should also work if you comment the line out with "#". I think you have a 2.6.x kernel installed. Then this is the default value and you don't need to set LD_ASSUME_KERNEL. About your previouse messeage. It can't find the libr3wid2.so because the directories are not in /etc/ld.so.conf.
An Example:

/usr/lib/qt-3.1/lib
/usr/lib/sane
/usr/lib/wine
#/usr/local/BMRT2.6/lib
/usr/lib/aqsis
/usr/X11R6/lib
/usr/local/lib
/usr/lib/qt-3.3/lib
#For RS3D SDK
$HOME/sdk/lib
#For RS3D V5
/usr/local/realsoft3d/lib
/usr/local/realsoft3d/plugins
/usr/local/realsoft3d/extlibs

su
/sbin/ldconfig

(if you add it to /etc/ld.so.conf you can comment out LD_LIBRARY_PATH in the script.
Or you don't set the LD_LIBRARY_PATH=..., if you run the binary directly. So it can't find libr3wid2.so. Linux has no build in AI. Only the Gimp Image Manipulation Program will check at compilation time for artificial intelligence (yeah thats true, just try make in the gimp sources :o ).
Regards Marc
Guest
 

Postby Guest » Wednesday 2. March 2005, 17:34

This image loading problem should only appear on RS3D versions before pre-V5 for Linux.
Guest
 

r3rendd without X

Postby Yogi » Wednesday 2. March 2005, 21:59

Hello,

I've installed the new V5.1 on a linux-box. It's Debian 3.1, says the file /etc/debian_version. X11-forwarding is activated on this box. If I start a X-Server on my windows-box, I can simply start r3rendd and take advantage of a higher rendering speed on my windows-box. :-) No window poped up. The X-Server is simply useless in this case.

But If I don't start my local X-Server, r3rendd doesn't start and simply says:
"./r3rendd
X connection to localhost:10.0 broken (explicit kill or server shutdown)."

So, how I start r3rendd without a X-Server?
User avatar
Yogi
 
Posts: 57
Joined: Wednesday 7. April 2004, 15:06

Postby odubtaig » Wednesday 2. March 2005, 23:16

As it is, this isn't actually running the software on the Windows box, it's putting the interface on the Windows box while all the non-interface code is run on the Linux box; it may look and feel like it's running on the Windows box, but if you go to save or load a file from a program running in this fashion, the truth it revealed.

So far as I can ascertain, the only way to get the Linux version to run on your Windows box, is to install Linux.

regards, Paul
User avatar
odubtaig
 
Posts: 54
Joined: Sunday 26. September 2004, 20:59
Location: Sheffield England

Postby Yogi » Wednesday 2. March 2005, 23:26

I think, you don't understand me correctly. I don't want to start realsoft3d on the linux-box. I simply want ot start the render-demon on the linux-box to use it from my windows-box. r3rendd is simply the render-demon. No GUI. But I need to start a X-Server on my windows-box to simply start r3rendd! But no window pops up. If I don't start the X-Server on my windows-box, r3rendd doesn't start. X11-forwarding is avtivated. This looks like a bug! As we have tested, even unsetting $DISPLAY or something like that doesn't help.
User avatar
Yogi
 
Posts: 57
Joined: Wednesday 7. April 2004, 15:06

Postby odubtaig » Wednesday 2. March 2005, 23:36

Yes, and I can see what you're trying to do, but when you're running it from the X-Server in Windows, it's still running on the Linux box, not the Windows box. All X11-forwarding does is push the interface to another machine, any non-interface code is still run on the Linux box e.g. if you were to run XMMS from the Windows box, the sound would still come out the Linux box's speakers.

Essentially, the command line equivelant would be to ssh (or, if you really don't care about security, telnet) logon into the Linux box and run the command from there.

regards, Paul
User avatar
odubtaig
 
Posts: 54
Joined: Sunday 26. September 2004, 20:59
Location: Sheffield England

Postby Yogi » Wednesday 2. March 2005, 23:46

Yes, I make a connection to this machine via SSH. I don't have a X-Server. So, tell me, how I simply start r3rendd? If I want to start it, it simply says, that I can't connect to a X-Server!

I think, we dont't understand each other. ;-)
And yes, I know how this X11-system works.
User avatar
Yogi
 
Posts: 57
Joined: Wednesday 7. April 2004, 15:06

Postby odubtaig » Thursday 3. March 2005, 00:05

I think what you really want to be looking into is batchren which you can just feed the file and it doesn't ask for a graphical display of any kind. If you select help >> reference manual on of the options will be batchren and it should tell you all you need to know to render still and animations.

regards, Paul
User avatar
odubtaig
 
Posts: 54
Joined: Sunday 26. September 2004, 20:59
Location: Sheffield England

Postby Guest » Thursday 3. March 2005, 06:52

Hi Yogi, also connecting from windows via ssh does not work or does it work? And then starting the r3rendd over the ssh connection via command line also does not work?
Guest
 

Material Browser does not show the materials with pre-V5

Postby Guest » Thursday 3. March 2005, 07:13

Please, don't mail this bug. To work around, press the "Up" button in the "Material Browser" window. Now should on the left side the directory tree of your RS3D installation directory appear. Select the "Material" directory in the tree view and you can choose a material you want to add. Before you do anything in the material browser save you current project :!: else :cry:
Guest
 

Postby Guest » Thursday 3. March 2005, 11:37

Hi Yogi, I checked this with two Linux boxes and it's not working without a running x server at the client. I opened a ssh connection to the server from the framebuffer console, tried to run r3rendd and got the error you described. This is no bug because if you probe the shared objects dependencies of the binary R3RendD with "ldd R3RendD" you will see that it needs X11, but I don't know for what?
Guest
 

Postby zaug » Thursday 3. March 2005, 11:44

Is there any way to get it to show materials in another directory besides /usr/local/ ?
User avatar
zaug
 
Posts: 225
Joined: Saturday 20. December 2003, 16:29
Location: USA

Postby Yogi » Saturday 5. March 2005, 23:16

methamorpheus wrote:Hi Yogi, I checked this with two Linux boxes and it's not working without a running x server at the client. I opened a ssh connection to the server from the framebuffer console, tried to run r3rendd and got the error you described. This is no bug because if you probe the shared objects dependencies of the binary R3RendD with "ldd R3RendD" you will see that it needs X11, but I don't know for what?


I think, this is a bug. At V4.x, r3rendd doesn't need X! The point is: When I want to simply setup a renderslave, why I have to install a full Realsoft3D-Distribution? And why I must have an X-Server to simply startup a console-application?
User avatar
Yogi
 
Posts: 57
Joined: Wednesday 7. April 2004, 15:06

PreviousNext

Return to Realsoft for Linux

Who is online

Users browsing this forum: No registered users and 3 guests

cron